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This Getting Started section of the APMS Online Training Manual will deal with items that are general to 
APMS and not specific to any T30 Types.  This section will focus on the following: 

       Accessing the APMS Program 
       APMS Menus and Toolbars 
       The APMS Main Screen 
       APMS Program Options 
       APMS Properties 
       APMS Type 30 Queue Maintenance 
       APMS Transaction Database Purge Control 
       APMS Factory Interface 

  

If you have any problems using the APMS Online Training Manual or need assistance with the APMS program, 
please contact APMS Technical Support at (541) 367-5086. 



 

 

Accessing the Program 

This manual assumes that you already have literacy in the use of a Personal Computer with 
Windows95, 98 or NT4.0 or higher.  You should also be a skilled user in DST Innovis Type 30 
Parameters to be able to fully understand the exercises presented in this training session.  
We will begin by providing a short orientation to the Automated Parameter Management 
System (APMS) navigation tools as they relate to the Microsoft operating systems and what 
you may expect to experience in their use. 

Overview:  Windows95, 98, NT4.0 and Windows 2000  

APMS installs on your workstation much like any other Windows compatible application that 
you are familiar with.  APMS will install to it’s own directory.  For ease of use, a shortcut to 
APMS can be set up to provide point and click access from the desktop.  

 

Security and Accessing T30’s  

An administrator controls access to the APMS application.  Each user needs to be authorized for access through 
a login process that is controlled by the designated administrator.  The administrator will define your “User 
Name” and initial “Password”.   You have an option to “Change Password” whenever you feel that it is 
necessary to preserve the integrity of the changes made under your User Name.  All Adds, Deletes, and 
Changes are recorded to the APMS Change Log by User Name. 

 



 

 

 

When you enter your User Name and password, you will also be prompted to enter the Corp Number for the 
system you want to access.  Upon entry to the APMS program, a check will be made to verify that the user 
entering APMS has access to the requested corp.   

If the user has permission to enter the corp, the program will continue on to the next login step.  If the corp 
being accessed is not setup for the user to access, a message will display informing the user that they are not 
setup for the corp. 

The Set Current Parameters window is presented to allow you to choose the Year, Month, and Cycle for which 
you want to update parameters and the Current DST Innovis Year/Month/Cycle.  Use the appropriate drop-
down lists to make your selections. 

 

The Current DST Innovis Year/Month/Cycle can be different than the Year/Month/Cycle that you are making 
changes for.  APMS needs to know which cycle you are making changes for and what the current DST Innovis 
cycle is.  This information is used in managing the data and transactions that are saved in the APMS 
Transaction Database and the Type 30 Queue Maintenance program.  



 

 

APMS Menus and Toolbar 

Following are examples of basic drop down and icon commands you have available in APMS that have a 
familiar feel to standard Microsoft commands.  Because this application was programmed with Microsoft 
literacy in mind, you will find that navigation in the program is intuitive to the average user. 

 

In addition to the buttons or icons, the familiar up, down, right left keypad allows for quick 
access to the various columns, rows, and fields within the individual parameters.   

File  

The File menu contains the following items: 

�       Open – Open an existing Type 30 database. The program displays the Select Corp Number window. Enter 
the corp number you want to access. 

�       New Corp – Use this option to open a database for another corp.  The program displays the Select Corp 
Number window.  Enter the corp number you want to access. 

�       Close – Close a database. 

�       Save – This option is unavailable. APMS saves your changes when you click OK when adding a parameter, 
or when you click outside the field when changing a parameter. 

�       Reports – Generate set-up reports, cross-reference reports, and change request forms. 

�       Properties – Use this to specify user information as well as specifying the cut-off date for your change 
request forms. 

�       Exit – Use this option to quit APMS. 

Edit  

The Edit menu contains the following items: 

�       Undo – This function is not now available, and is being reevaluated. If you have any questions about this 
function’s availability, contact APMS Technical Support. 

�       Copy – Use this option to copy data from an existing rate code to a new rate code. 

�       Cut – This feature is not available and is currently being re-evaluated.  If you have any questions about this 
function’s availability, please contact APMS Technical support. 



 

 

�       Paste – This feature is not available and is currently being re-evaluated.  If you have any questions about 
this function’s availability, please contact APMS Technical support. 

�       Add Record – For multiple-row Type 30 parameters, such as the Rate Table and the Reporting Center 
Table, adds a new row to the table. 

�       Delete Record – For multiple-row Type 30 parameters, deletes the record from the table. You can also use 
the ‘–‘ button on the tool bar to delete a record. 

�       Comments – Opens the Comments window so that you can review or enter comments about a parameter. 

Note:  All of the functions in the Edit Menu are also available from the Tool Bar. 

View 

The View menu contains the following items: 

�       Tool Bar – Turns the tool bar at the top of the screen on or off. 

�       Status Bar – Turns the status bar at the bottom of the screen on or off. 

�       Changed Data – Highlights the parameters that you have changed for the month/cycle that you are 
accessing. 

�       Cycle Selector – Displays the Set Current Parameters window so that you can specify a new cycle for 
updating. 

�       Options – Use this option to specify preferences for the APMS program, such as default settings when you 
start the program and how the record grids appear. 

Tools  

The Tools menu contains the following items: 

�       Spell Checker – This option is no longer used for spell checking in the T20 Messages.  T20 message text 
can be spell checked using the Spell Check button in the T20 Message Add/Edit box. 

�       T30 Interface – Opens the Factory Interface window so you can upload your Type 30 parameter changes to 
the Tandem at Output Technology Solutions. 

�       Database Administrator – Allows the administrator the options for defining users, adding databases, setting 
security levels, and printing a report of the people authorized to use the program.  This option is available 
only if you log in to the program using a System Administrator or higher access. 

�       Database Utilities – Compresses or repairs the APMS databases. When you choose this, the program 
displays a window so that you can choose the database, and whether you want to Compact or Repair the 
database or both.  

�       Update Software – Use this option to link to Concise Solutions web site so that you can download updates.  
When you choose this option, the program launches your web browser and directs it to the download area. 



 

 

�       Statement Presentation – Use this option to see how a sum code and its related extensions print on a 
customer's statement. You must first choose a sum code from Type 30-09 (Sum Codes and Extensions) to 
use this option. 

�       ParaCompare – An optional additional program that allows you to compare your DDP Financial parameters 
to the parameters set up in DDP/SQL.  You can choose to compare rate codes, reporting centers, or 
adjustment reasons. 

�       T30 Queue Maintenance – Use this option to review and accept Type 30 parameter changes. 

�       Find a Rate Code – Use this option to display parameters on specific rate codes. 

�       Copy Corp Files – Use this option to create a play corp for your users with existing data from a live corp.  
This option is available only if you log in to the program using a System Administrator or higher access. 

Help 

Use the options on the Help menu to access online Help on APMS and version information. 

Toolbar Buttons  

While you are working with a Type 30 parameter, the following buttons on the tool bar are available: 

 

 

 

 



 

 

 

 

 

 

 

 

 



 

 

 

 

 

 

 

 



 

 

 

Type 30 Module Buttons  

Each Type 30 module contains buttons such as OK, Cancel, and Apply.  

�       OK  and Cancel – These two buttons display when a Type 30 module has a single form with no tabs and no 
continuing screens.  OK  implements the change; Cancel leaves the form without implementing the change. 

�       OK, Apply, and Cancel – These three buttons display when a Type 30 module has a single form with 
multiple tabs and continuing screens.  OK  implements the outstanding changes and closes the form.  Apply  
implements the changes made up to that point but does not close the form.  Cancel leaves the form without 
implementing any changes since the last time you pressed Apply . 

�       Back, Next, Cancel, and Finish – These four buttons display when a Type 30 has multiple screens.  Back 
returns you to the previous screen.  Next advances you to the next screen.  Cancel leaves the form(s) 
without making any changes.  Finish goes to the end of the screens using the default values for the 
intermediate screens. 



 

 

Shortcut Keys  

When accessing a Type 30 parameter, you can use the following keys to navigate: 

�       tab key - Moves the cursor one cell to the right. 

�       Shift+tab key - Moves the cursor one cell to the left. 

�       arrow key - Moves the cursor in the direction of the arrow key. 

�       Page Up key - Moves the cursor up one page. 

�       Page Down key - Moves the cursor down one page. 

�       Home key - Moves the cursor to the first column in the table (or the split if the table is split).  

�       End key - Moves the cursor to the last column in the table (or the split if the table is split).  

�       Ctrl+Home key - Same as Home key, but positions the current row at the first row in the table.  

�       Ctrl+End key - Same as End key, but positions the current row at the last row in the table.  

�       Alt+down arrow key - Drops down the list box. Use the mouse or arrow keys to navigate within the drop-
down list. (You can also left-click on the drop-down list’s down arrow to display the drop-down list.) 

Special Function Keys  

 

�       F1 – Access Help. 

�       F2 – Enter edit mode when the cursor is in a description field. This changes the cursor to an insertion point 
so that you can edit the text in the field. 

�       F3 – Insert a time stamp when the cursor is in the Comment field.  



 

 

�       F4 – Sort data in a parameter. The program prompts you for the column to sort on, and then sorts the grid 
based on the values in the column. 

 

�       F5 – Find or select a parameter value. This brings up a window where you specify the column you want 
to search or select on, and the value you want to find or select. The program then highlights all records 
matching your criteria. 

 

Key Terms  

CHANGE REQUEST FORMS – Reports resembling set-up reports with additional flags indicating 
parameters you have changed and those you have set to delete. 

CROSS-REFERENCE REPORTS – Reports providing further details on your parameters for research. You 
choose from the following types: parameters used and not used, parameters associated with other parameters 
(for example, the rate codes associated with each reporting center), or comments about the parameters. 



 

 

APMS SOURCE DATABASE – The database containing information that the APMS program uses to accept 
your changes, display the parameters, and generate reports.  

CORP TRANSACTION DATABASE  – The database containing your changes to your parameters. When you 
request a change request form, the program prints formatted records from the transaction database. 

VALIDATION DATABASE  – The database containing default values for the Type 30 parameters, as well as 
valid entries for each field. When you access a field with a drop-down menu, the program reads this database 
for the values to display. 

CORP DATA DATABASE  – Contains the Type 30 parameter values specific to the DST Innovis corp. 



 

 

APMS Main Screen 

Type 30 Parameters Drop Down  

 



 

 

Once you have selected the cycle and the database, a drop-down list of parameters is displayed to give you 
access to the Type 30 options for add, change, or delete.  By selecting a specific type 30 option, that option is 
displayed and available for your use. 

Status Bar  

 

The Status Bar displays at the bottom of the screen. It always contains the following information: The Type 30 
parameter you currently have open, the month, year, and code of the cycle for which you are updating Type 30 
parameters, and the current date and time. Depending on the Type 30 you are accessing, additional information 
displays in this line. Refer to the topic on the specific Type 30 for additional information. 

 



 

 

Program Options 

Use the Options window from the View menu to specify preferences for the APMS program, such as default 
settings for startup and how the All Records tabs appear. 

 

General Tab  

Use these parameters to specify default settings for startup. 

Default Database at Startup - Use this field to choose the default database: the last database you accessed 
or a new one you select. 

Show Tooltips at Startup - Use this field to show or not show the Tip of the Day window when you start 
the program. 

Enter T16 Amounts with Decimal - Use this field to specify if you will enter the T16 Rate Amount with or 
without a decimal.  As an example:  

If you have this field set to No, an entry of 500 in a Rate Amount field will become $5.00. 

If you have this field set to “Yes”, an entry of 500 in a Rate Amount field will become $500.00. 



 

 

Save Original Database – Use this field to create a back up copy of the files you are opening when you 
select a corp to access in APMS.  This feature creates duplicate Corp Data and Transaction Databases on the 
server upon opening of the corp.  

 

All Record Grids Tab 

Use these parameters to customize the appearance of multiple-row parameters, such as the Rate Table and the 
Reporting Center table.  

Save Column Parameters – Select this option to have the program retain your changes to a record grid, for 
example, if you change the sizes of the columns  

Changed Field Color – Use this field to specify the highlight color for changed fields.   

Sort Options: Save Sorts – Select this option to have the program retain your sorts of record grids. 

Select Options: Save Selects – Select this option to have the program retain your selects  

Selection Color – Use this field to specify the highlight color for selected records. 



 

 

APMS Properties 

Use the Properties window from the File menu to specify user information, and information about the 
parameters you are entering.  

    

User Data 

Use this tab to enter your name, an alternate contact name, and telephone and beeper numbers.  

 

Corp Data 

Use this tab to specify information about the DDPF update run that you are entering parameters for. 

  

Update Month/Cycle – The program displays the month, cycle, and year you chose in the Set Current 
Parameters window when you started the program. 

Next Cutoff Date – Enter the default date for the change request forms. When you create a change request 

form, you can use this date or specify another.  



 

 

DDP Release – If needed, choose a new release number. Use caution when changing this value, since it 

controls edits that the APMS program uses when verifying your parameter entries. If you set this to an 

incorrect value, you could have database problems during your next DDP-F update. 

DDPF Release – If needed, choose a new DDPF Release.  This field will control aspects of corp specific 

DDPF  Data (i.e. changing from Release QB to Release RA will give Tennessee Users the ability to enter 

the T22M Graduated Tax data). 

 



 

 

APMS Type 30 Queue Maintenance 

When you select T30 Queue Maintenance from the Tools menu, the program displays two tabs: 

T30 Queue Maintenance - Use this tab to verify and accept Type 30 changes. 

 



 

 

T30 Queue Reports - Use this tab to print reports of Type 30 changes. 

 

Verifying and Accepting Type 30 Changes 

Click the T30 Queue Maintenance tab.  On this tab, the program displays the following: 

�       the Type 30 type that was changed 

�       the Type 30 code where applicable, for example, ‘30’ for a change to Reporting Center 30 

�       the name of the operator who made the change 

�       the type of change (new record, deleted record, changed record) 

�       the date and time of the change 

After verifying a change, click in the Accept column. The program removes this queue entry from the screen 
and writes the Type 30 change to the History file along with the date and time you accepted the change, and 
your name. 

Use the Record Selection button to choose whether to display the pending records in the queue or the accepted 
records in the History file. If you choose History file records, the program prompts you to enter the date range 
for when the change was made. 

Note:  If the Factory Interface finds any unaccepted Type 30 changes for the corp, month, cycle, and year, it 
halts and does not transmit any parameter changes to OTS. 



 

 

Printing Type 30 Changes 

Click the T30 Queue Reports tab. You can either choose a month, cycle, or year for the report, or enter a date 
range for when the change was made. Check the Print Preview box if you want to display the report. Finally, 
choose one of the following types of records for the report: 

�       Active Records - Print only those records still in the Type 30 Queue 

�       History Records - Print accepted records that are in the History file 

�       Both/Actv + Hist - Include both types of records in the report. 

Click OK  to print the report; Cancel to exit the window without printing the report. 



 

 

APMS Transaction Database Purge Control 

APMS allows the user to go forward or backward to specific cycle to not only control the parameters in the 
future but to allow research into changes made in the past.  As a result the amount of information stored in the 
Transaction Database can become quite large over a period of time.  Transaction Database Purge Control allows 
you to delete (purge) old historical entries from the Transaction Database. 

 

�       Upon entry into APMS, the user is not only asked for the month/cycle they want to work in, but also the 
current DST Innovis month/cycle for the corp. 

�       Once in APMS, access the View/Options menu.  In this Options box, there is a tab called TransactionDB 
Params.  On this tab, select how you want to handle the database historical purge.  You have the option of 
deleting records that are ‘so many’ month/cycles in the past or deleting old records to keep them under a 
limit of how many records they choose to keep.  Concise Solutions recommends the ‘number of cycles’ 
option.   

Upon closing APMS, the corp transaction database will be compared to the settings for purging historical 
entries and remove any that meet the criteria setup. 

Note:  This is a secured option.  The default settings are to save records for 99 Cycles.  If you want to change 
these setting, please contact Concise Solutions APMS Technical Support.



 

 

APMS Factory Interface 

Access the T30 Interface option from the Tools menu to update the Tandem at Output Technology Solutions 
with your parameter changes.  

Before accessing this option, use T30 Queue Maintenance from the Tools menu to verify and accept your 
parameter changes.  If the Factory Interface finds any unaccepted Type 30 changes for the corp, month, cycle, 
and year, it halts and does not transmit any parameter changes to OTS.  

Notes:  

�       The Factory Interface field must be set to “Yes” to use the Factory Interface. This field is in the Options 
window from the View menu. 

�       The first time you access this option you must set up certain parameters. Please contact Concise Solutions 
APMS Technical Support to verify the setup of the Factory Interface program. 

When you access this option, the Factory Interface window displays.  The display-only fields in this window 
show your ID as an Online Type 30 Parameters user, your corp number, and the month, year, and cycle of the 
parameters you are transmitting.  The program uses the bottom line of this window to display status messages 
during the update. 

 

After you click Begin, the program does the following: 

1. Creates an audit log file, giving it a name in the format Auditlog_ 

yymmddhhmm.txt, where yy is the year, mm is the month, dd is the day, hh is the hour and mm is the minute 
the file was created. 

2. Creates an export file, giving it a name in the format cmm#####, where c is the cycle, mm is the month and 
##### is your corp number. 

3. Establishes a PPP (point-to-point protocol) connection to the Tandem at Output Technology Solutions (OTS), 
and transmits the file. 

4. A program running on the Tandem at OTS recognizes when the file has been completed through the PPP 
connection and automatically initiates the program that merges the Type 30 data from APMS into the Tandem 
Type 30 file.  As the Type 30s are being merged, a Transaction Log file (TL file) is being created that shows the 
progress of the Type 30’s during processing. 

5. After a set amount of time, the Factory Interface program will contact the Tandem at OTS through the PPP 
connection and will attempt to locate the completed TL file.  Once the completed TL file is located, the program 



 

 

will copy it back to the user’s PC.  From this file, the program will display onscreen whether or not the merging 
of the T30 data completed successfully. 

Note: If the program encounters a problem when transmitting your parameters to OTS, it writes the error to the 
audit log. This helps Customer Care personnel in diagnosing and fixing the problem. 

 

 


